Überblick
Die Schaltfläche Nach Excel exportieren in der Befehlsleiste von My Tasks speichert Ihre aktuelle Aufgabenliste in einer Datei, die Excel direkt öffnen kann. Das ist praktisch, wenn Sie einen Statusbericht vorbereiten, Aufgaben anders sortieren möchten, als es das Webpart anbietet, Aufgaben pro Projekt zählen oder einfach eine Momentaufnahme Ihrer Arbeitslast aufbewahren wollen.
Der Export enthält die Aufgaben, die Sie in diesem Moment in der Liste sehen. Er berücksichtigt Ihre Filter und die Sortierung und umfasst alle Seiten der Liste, nicht nur die aktuell angezeigte.
So exportieren Sie
- Warten Sie, bis die Liste vollständig geladen ist. Solange Aufgaben geladen werden oder gar keine Aufgaben vorhanden sind, ist die Schaltfläche nicht verfügbar.
- Wenn Sie nur einen Teil der Aufgaben benötigen, wenden Sie zuerst die Filter an: das Menü Fälligkeitsdatum (Alle Daten, Überfällig, Heute, Diese Woche) und den Bereich Filter. Legen Sie außerdem die gewünschte Sortierung fest. Siehe KB10293. My Tasks: Filtern, Sortieren und persönliche Ansichtseinstellungen.
- Klicken Sie in der Befehlsleiste auf Nach Excel exportieren.
- Der Browser lädt die Datei herunter. Je nach Browsereinstellungen wird sie im Ordner „Downloads“ gespeichert, oder der Browser fragt nach dem Speicherort.
- Öffnen Sie die Datei in Excel.

Was exportiert wird
- Alle Seiten. Hat die Liste 120 Aufgaben und beträgt die Seitengröße 20, enthält die Datei alle 120 Aufgaben und nicht nur die 20 auf dem Bildschirm.
- Gefiltert und sortiert. Die Datei enthält die Aufgaben, die nach Anwendung des Schnellfilters Fälligkeitsdatum und des Bereichs Filter übrig bleiben – in der aktuell eingestellten Sortierung.
- Unabhängig von den Spalteneinstellungen. Der Spaltensatz der Datei ist fest und hängt nicht davon ab, welche Spalten auf der Seite sichtbar sind.
- Ausgeschlossene Status sind nicht enthalten. Aufgaben, die über die Einstellung Ausgeschlossene Status (Komma getrennt) ausgeblendet werden, werden nicht geladen und daher auch nicht exportiert; siehe KB10298. My Tasks: Status ausschließen und die Aufgabenliste begrenzen.
Spalten in der Datei
| Spalte | Inhalt |
|---|---|
| Quelle | Planner, To Do, Outlook, SharePoint, Projekt oder Azure DevOps |
| Vorgangsname | Der Titel der Aufgabe |
| Projektname | Projekt, Plan, Liste oder Website |
| Vorgangsstatus | Der Status |
| Priorität | Die Priorität |
| Erstellt am | Das Erstellungsdatum im Datumsformat Ihres Browsers |
| Fälligkeitsdatum | Das Fälligkeitsdatum im Datumsformat Ihres Browsers; leer, wenn keines vorhanden ist |
| Autor | Der Name des Autors; leer bei To-Do- und Outlook-Aufgaben |
| Kategorien | Alle Tags der Aufgabe in einer Zelle, getrennt durch Semikolon und Leerzeichen |
| URL | Die Adresse der ursprünglichen Aufgabe |
Die Spaltenüberschriften stehen in der Oberflächensprache des Webparts. Die Datumsangaben enthalten keine Uhrzeit und folgen dem regionalen Format Ihres Browsers; dieselbe Aufgabe kann daher auf einem Computer als 10/16/2026 und auf einem anderen als 16.10.2026 erscheinen.
Die Datei
Der Dateiname enthält das Exportdatum: my-tasks-2026-10-16.csv bei einem Export am 16. Oktober 2026.
Die Datei ist eine CSV-Datei (durch Kommas getrennte Werte) in der Kodierung UTF-8 mit Byte-Order-Mark (BOM). Das BOM weist Excel an, die Datei als UTF-8 zu lesen, sodass kyrillische, chinesische, japanische und andere nicht lateinische Zeichen in Aufgabentiteln korrekt angezeigt werden. Die Werte sind durch Kommas getrennt, die Zeilen durch Zeilenumbrüche; Werte, die Kommas, Anführungszeichen oder Zeilenumbrüche enthalten, stehen in Anführungszeichen.
📝 Hinweis
Obwohl die Schaltfläche Nach Excel exportieren heißt, ist die Datei keine .xlsx-Arbeitsmappe, sondern eine CSV-Datei, die Excel als Tabelle öffnet. In Excel können Sie sie über Datei > Speichern unter als Excel-Arbeitsmappe speichern.
Die Datei in Excel öffnen
Doppelklicken Sie auf die heruntergeladene Datei. In den meisten Installationen zeigt Excel die Spalten korrekt an.
Erscheinen alle Daten in einer Spalte, verwenden Ihre Windows-Regionseinstellungen ein Semikolon als Listentrennzeichen, und Excel erwartet Semikolons. Importieren Sie die Datei dann, statt sie zu öffnen:
- Öffnen Sie in Excel eine leere Arbeitsmappe und wählen Sie Daten > Aus Text/CSV.
- Wählen Sie die heruntergeladene Datei aus.
- Stellen Sie in der Vorschau Trennzeichen auf Komma und vergewissern Sie sich, dass Dateiursprung auf 65001: Unicode (UTF-8) steht.
- Klicken Sie auf Laden.
❗ Wichtig
Die Datei enthält Namen, Links und weitere Daten Ihrer Aufgaben. Speichern und teilen Sie sie gemäß den Regeln Ihrer Organisation. Der Export wird von Ihrem Browser auf Ihrem Computer erstellt; das Webpart sendet die Datei nirgendwohin.
💡 Tipp
Markieren Sie in Excel die Daten und wählen Sie Einfügen > Tabelle, um Filter und Sortierung in den Überschriften zu erhalten, oder erstellen Sie eine PivotTable, um Aufgaben nach Projektname oder Vorgangsstatus zu zählen. Um vor dem Export zu prüfen, welche Aufgaben enthalten sind, nutzen Sie den Schnellfilter Überfällig, der in KB10292. My Tasks: Spalte „Fälligkeitsdatum“, überfällige Aufgaben hervorheben und Schnellfilter beschrieben ist.
Wenn die Datei unvollständig ist
Enthält die Datei weniger Aufgaben als erwartet, prüfen Sie die Filter (ein ausgefülltes Symbol Filter oder ein anderer Wert als Alle Daten im Menü Fälligkeitsdatum bedeutet, dass ein Filter aktiv ist), die ausgeschlossenen Status und ob alle Datenquellen geladen wurden. Datenquellen, die sich nicht laden lassen, werden übersprungen. Siehe KB10307. Warum werden meine Aufgaben in My Tasks nicht angezeigt oder nicht geladen?. Die Einstellungen für den Seitenwechsel der Liste auf dem Bildschirm sind in KB10297. My Tasks: Seitengröße, Zeilenlimit, automatische Aktualisierung und sofortiges Laden beschrieben.